问题描述
读入n名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。
输入格式:每个测试输入包含1个测试用例,格式为
第1行:正整数n
第2行:第1个学生的姓名 学号 成绩
第3行:第2个学生的姓名 学号 成绩
… … …
第n+1行:第n个学生的姓名 学号 成绩
其中姓名和学号均为不超过10个字符的字符串,成绩为0到100之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。 输出格式:对每个测试用例输出2行,第1行是成绩最高学生的姓名和学号,第2行是成绩最低学生的姓名和学号,字符串间有1空格。
输入样例:
3 Joe Math990112 89 Mike CS991301 100 Mary EE990830 95
输出样例:
Mike CS991301
Joe Math990112
code
#include <stdio.h>
#include <stdlib.h>
int main()
{
int n, i;
typedef struct students
{
char id[11];
char name[11];
int score;
struct students *next;
}student;
student *ptr = (student *) malloc( sizeof(student) );
student *head = ptr;
student *temp = head;
student *max = head;
student *min = head;
scanf( "%d", &n );
for ( i = 0; i < n; i++ )
{
scanf( "%s %s %d", ptr->id, ptr->name, &(ptr->score) );
if ( i != n - 1 )
{
ptr->next = (student *) malloc( sizeof(student) );
ptr = ptr->next;
}
}
ptr->next = NULL;
for (; temp != NULL; temp = temp->next )
{
if ( max->score < temp->score )
max = temp;
if ( min->score > temp->score )
min = temp;
}
printf( "%s %s\n", max->id, max->name );
printf( "%s %s\n", min->id, min->name );
return(0);
}